2011年10月11日 星期二

Protocol Numbers


Assigned Internet Protocol Numbers

Registration Procedures
IESG Approval or Standards Action
Reference
[RFC5237]
Note
In the Internet Protocol version 4 (IPv4) [RFC791] there is a field
called "Protocol" to identify the next level protocol.  This is an 8
bit field.  In Internet Protocol version 6 (IPv6) [RFC2460], this field
is called the "Next Header" field.
DecimalKeyword Protocol Reference 
0HOPOPTIPv6 Hop-by-Hop Option[RFC2460]
1ICMPInternet Control Message[RFC792]
2IGMPInternet Group Management[RFC1112]
3GGPGateway-to-Gateway[RFC823]
4IPv4IPv4 encapsulation[RFC2003]
5STStream[RFC1190][RFC1819]
6TCPTransmission Control[RFC793]
7CBTCBT[Tony_Ballardie]
8EGPExterior Gateway Protocol[RFC888][David_Mills]
9IGPany private interior gateway (used by Cisco for their IGRP)[Internet_Assigned_Numbers_Authority]
10BBN-RCC-MONBBN RCC Monitoring[Steve_Chipman]
11NVP-IINetwork Voice Protocol[RFC741][Steve_Casner]
12PUPPUP[Boggs, D., J. Shoch, E. Taft, and R. Metcalfe, "PUP: An Internetwork Architecture", XEROX Palo Alto Research Center, CSL-79-10, July 1979; also in IEEE Transactions on Communication, Volume COM-28, Number 4, April 1980.][[XEROX]]
13ARGUSARGUS[Robert_W_Scheifler]
14EMCONEMCON[]
15XNETCross Net Debugger[Haverty, J., "XNET Formats for Internet Protocol Version 4", IEN 158, October 1980.][Jack_Haverty]
16CHAOSChaos[J_Noel_Chiappa]
17UDPUser Datagram[RFC768][Jon_Postel]
18MUXMultiplexing[Cohen, D. and J. Postel, "Multiplexing Protocol", IEN 90, USC/Information Sciences Institute, May 1979.][Jon_Postel]
19DCN-MEASDCN Measurement Subsystems[David_Mills]
20HMPHost Monitoring[RFC869][Robert_Hinden]
21PRMPacket Radio Measurement[Zaw_Sing_Su]
22XNS-IDPXEROX NS IDP["The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", AA-K759B-TK, Digital Equipment Corporation, Maynard, MA. Also as: "The Ethernet - A Local Area Network", Version 1.0, Digital Equipment Corporation, Intel Corporation, Xerox Corporation, September 1980. And: "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specifications", Digital, Intel and Xerox, November 1982. And: XEROX, "The Ethernet, A Local Area Network: Data Link Layer and Physical Layer Specification", X3T51/80-50, Xerox Corporation, Stamford, CT., October 1980.][[XEROX]]
23TRUNK-1Trunk-1[Barry_Boehm]
24TRUNK-2Trunk-2[Barry_Boehm]
25LEAF-1Leaf-1[Barry_Boehm]
26LEAF-2Leaf-2[Barry_Boehm]
27RDPReliable Data Protocol[RFC908][Robert_Hinden]
28IRTPInternet Reliable Transaction[RFC938][Trudy_Miller]
29ISO-TP4ISO Transport Protocol Class 4[RFC905][]
30NETBLTBulk Data Transfer Protocol[RFC969][David_Clark]
31MFE-NSPMFE Network Services Protocol[Shuttleworth, B., "A Documentary of MFENet, a National Computer Network", UCRL-52317, Lawrence Livermore Labs, Livermore, California, June 1977.][Barry_Howard]
32MERIT-INPMERIT Internodal Protocol[Hans_Werner_Braun]
33DCCPDatagram Congestion Control Protocol[RFC4340]
343PCThird Party Connect Protocol[Stuart_A_Friedberg]
35IDPRInter-Domain Policy Routing Protocol[Martha_Steenstrup]
36XTPXTP[Greg_Chesson]
37DDPDatagram Delivery Protocol[Wesley_Craig]
38IDPR-CMTPIDPR Control Message Transport Proto[Martha_Steenstrup]
39TP++TP++ Transport Protocol[Dirk_Fromhein]
40ILIL Transport Protocol[Dave_Presotto]
41IPv6IPv6 encapsulation[RFC2473]
42SDRPSource Demand Routing Protocol[Deborah_Estrin]
43IPv6-RouteRouting Header for IPv6[Steve_Deering]
44IPv6-FragFragment Header for IPv6[Steve_Deering]
45IDRPInter-Domain Routing Protocol[Sue_Hares]
46RSVPReservation Protocol[Bob_Braden]
47GREGeneral Routing Encapsulation[Tony_Li]
48DSRDynamic Source Routing Protocol[RFC4728]
49BNABNA[Gary Salamon]
50ESPEncap Security Payload[RFC4303]
51AHAuthentication Header[RFC4302]
52I-NLSPIntegrated Net Layer Security TUBA[K_Robert_Glenn]
53SWIPEIP with Encryption[John_Ioannidis]
54NARPNBMA Address Resolution Protocol[RFC1735]
55MOBILEIP Mobility[Charlie_Perkins]
56TLSPTransport Layer Security Protocol using Kryptonet key management[Christer_Oberg]
57SKIPSKIP[Tom_Markson]
58IPv6-ICMPICMP for IPv6[RFC2460]
59IPv6-NoNxtNo Next Header for IPv6[RFC2460]
60IPv6-OptsDestination Options for IPv6[RFC2460]
61any host internal protocol[Internet_Assigned_Numbers_Authority]
62CFTPCFTP[Forsdick, H., "CFTP", Network Message, Bolt Beranek and Newman, January 1982.][Harry_Forsdick]
63any local network[Internet_Assigned_Numbers_Authority]
64SAT-EXPAKSATNET and Backroom EXPAK[Steven_Blumenthal]
65KRYPTOLANKryptolan[Paul Liu]
66RVDMIT Remote Virtual Disk Protocol[Michael_Greenwald]
67IPPCInternet Pluribus Packet Core[Steven_Blumenthal]
68any distributed file system[Internet_Assigned_Numbers_Authority]
69SAT-MONSATNET Monitoring[Steven_Blumenthal]
70VISAVISA Protocol[Gene_Tsudik]
71IPCVInternet Packet Core Utility[Steven_Blumenthal]
72CPNXComputer Protocol Network Executive[David Mittnacht]
73CPHBComputer Protocol Heart Beat[David Mittnacht]
74WSNWang Span Network[Victor Dafoulas]
75PVPPacket Video Protocol[Steve_Casner]
76BR-SAT-MONBackroom SATNET Monitoring[Steven_Blumenthal]
77SUN-NDSUN ND PROTOCOL-Temporary[William_Melohn]
78WB-MONWIDEBAND Monitoring[Steven_Blumenthal]
79WB-EXPAKWIDEBAND EXPAK[Steven_Blumenthal]
80ISO-IPISO Internet Protocol[Marshall_T_Rose]
81VMTPVMTP[Dave_Cheriton]
82SECURE-VMTPSECURE-VMTP[Dave_Cheriton]
83VINESVINES[Brian Horn]
84TTPTTP[Jim_Stevens]
84IPTMProtocol Internet Protocol Traffic Manager[Jim_Stevens]
85NSFNET-IGPNSFNET-IGP[Hans_Werner_Braun]
86DGPDissimilar Gateway Protocol[M/A-COM Government Systems, "Dissimilar Gateway Protocol Specification, Draft Version", Contract no. CS901145, November 16, 1987.][Mike_Little]
87TCFTCF[Guillermo_A_Loyola]
88EIGRPEIGRP[Cisco Systems, "Gateway Server Reference Manual", Manual Revision B, January 10, 1988.][Guenther_Schreiner]
89OSPFIGPOSPFIGP[RFC1583][John_Moy]
90Sprite-RPCSprite RPC Protocol[Welch, B., "The Sprite Remote Procedure Call System", Technical Report, UCB/Computer Science Dept., 86/302, University of California at Berkeley, June 1986.][Bruce Willins]
91LARPLocus Address Resolution Protocol[Brian Horn]
92MTPMulticast Transport Protocol[Susie_Armstrong]
93AX.25AX.25 Frames[Brian_Kantor]
94IPIPIP-within-IP Encapsulation Protocol[John_Ioannidis]
95MICPMobile Internetworking Control Pro.[John_Ioannidis]
96SCC-SPSemaphore Communications Sec. Pro.[Howard_Hart]
97ETHERIPEthernet-within-IP Encapsulation[RFC3378]
98ENCAPEncapsulation Header[RFC1241][Robert_Woodburn]
99any private encryption scheme[Internet_Assigned_Numbers_Authority]
100GMTPGMTP[[RXB5]]
101IFMPIpsilon Flow Management Protocol[Bob_Hinden][November 1995, 1997.]
102PNNIPNNI over IP[Ross_Callon]
103PIMProtocol Independent Multicast[Dino_Farinacci]
104ARISARIS[Nancy_Feldman]
105SCPSSCPS[Robert_Durst]
106QNXQNX[Michael_Hunter]
107A/NActive Networks[Bob_Braden]
108IPCompIP Payload Compression Protocol[RFC2393]
109SNPSitara Networks Protocol[Manickam_R_Sridhar]
110Compaq-PeerCompaq Peer Protocol[Victor_Volpe]
111IPX-in-IPIPX in IP[CJ_Lee]
112VRRPVirtual Router Redundancy Protocol[RFC3768][RFC5798]
113PGMPGM Reliable Transport Protocol[Tony_Speakman]
114any 0-hop protocol[Internet_Assigned_Numbers_Authority]
115L2TPLayer Two Tunneling Protocol[Bernard_Aboba]
116DDXD-II Data Exchange (DDX)[John_Worley]
117IATPInteractive Agent Transfer Protocol[John_Murphy]
118STPSchedule Transfer Protocol[Jean_Michel_Pittet]
119SRPSpectraLink Radio Protocol[Mark_Hamilton]
120UTIUTI[Peter_Lothberg]
121SMPSimple Message Protocol[Leif_Ekblad]
122SMSM[Jon_Crowcroft]
123PTPPerformance Transparency Protocol[Michael_Welzl]
124ISIS over IPv4[Tony_Przygienda]
125FIRE[Criag_Partridge]
126CRTPCombat Radio Transport Protocol[Robert_Sautter]
127CRUDPCombat Radio User Datagram[Robert_Sautter]
128SSCOPMCE[Kurt_Waber]
129IPLT[[Hollbach]]
130SPSSecure Packet Shield[Bill_McIntosh]
131PIPEPrivate IP Encapsulation within IP[Bernhard_Petri]
132SCTPStream Control Transmission Protocol[Randall_R_Stewart]
133FCFibre Channel[Murali_Rajagopal][RFC6172]
134RSVP-E2E-IGNORE[RFC3175]
135Mobility Header[RFC6275]
136UDPLite[RFC3828]
137MPLS-in-IP[RFC4023]
138manetMANET Protocols[RFC-ietf-manet-iana-07]
139HIPHost Identity Protocol[RFC5201]
140Shim6Shim6 Protocol[RFC5533]
141WESPWrapped Encapsulating Security Payload[RFC5840]
142ROHCRobust Header Compression[RFC5858]
143-252Unassigned[Internet_Assigned_Numbers_Authority]
253Use for experimentation and testing[RFC3692]
254Use for experimentation and testing[RFC3692]
255Reserved[Internet_Assigned_Numbers_Authority]

2011年9月26日 星期一

RFID(無線射頻辨識 Radio Frequency Identification)

RFID(無線射頻辨識 Radio Frequency Identification)靠著非接觸性讀取晶片資料,具有非接觸式讀取、資料容量大且可更新、可重複使用、可同時讀取多個辨識標籤、資料安全性佳等特點,比起現行必需逐一刷過條碼才能讀取資料的技術更先進、更快速,不但可以運用在物流管理、運輸管理,甚至可以用在醫院、國防、藥品防偽、安全管理上,將打造產業巨大的革命。
 
RFID系統架構可分為電子標籤(Tag)、掃讀器(Reader)、天線(Antenna)三種。而電子標籤又分為被動式與主動式;
       主動傳輸RF信號的RFID單元稱為主動式標籤,它可讀寫並可重複使用;其記憶體大小可應需求而變化,有些甚至可達1MB,價格較昂貴,使用週期較短。其應用市場主要是國防醫療,如需要快速定位與讀取資料的軍事醫療;及些許工業市場,如交通道路自動收票、付費/保險紀錄的車輛管理運用。
        而將僅進行RF信號反射或反向散射傳輸的RFID單元稱為被動式標籤,它唯讀,不可重複使用,主要負責儲存被識別物的袺鷏穈T,如品名、編號、規格等;此外價格較便宜、無限使用週期、讀取區域較近。主要應用於快速紀錄追蹤,如動物管理;防盜防遺失,如門禁與貨運管理;還有消費市場應用,如超級市場產品管理。
低頻/中頻/高頻/微波

Tag的等級分類表
等級(Class)記憶體電源特性應用領域
Class 0無被動式的感應偶合1位元的TagEAS商品防竊
Class 1唯讀式被動式的感應偶合只能寫入一次EPC識別碼
Class 2讀/寫式被動式的感應偶合可編密碼EPC識別碼
Class 3讀/寫式半被動式內建有電源接收能量才讀寫環境感應型
Class 4讀/寫式主動式內建有電源多工Tag讀寫智慧型
Class 5讀/寫式主動式內建有電源具有上述的綜合遠距無線網路

Tag與頻率的關係

頻率

低頻(LF 125 KHz)高頻
(
HF; 13.56 MHz)
超高頻(UHF; 860-930 MHz)微波(2.45- 5.8 MHz)
性統型態被動式1444315693被動式主動式被動式主動式
讀取距離<0.5m<0.5m<1.5m3-10m>10m3-10m>10m
記憶體bytes64-1k8k-128k256k-512k64k-512k-16k-64k-
傳輸功率72dBμA/m42dBμA/m10mW-4W4W(USA),0.5W
讀取方法感應線圈感應線圈電容式電場效應電容式電場效應
讀取速度
慢 ←→ 快
環境適應性
佳 ←→ 差
尺寸
大 ←→ 小

應用領域可包括如下:
Ø交通運輸:高速公路的收費系統、停車場出入管控、交通流量...
Ø貨物管理:航空、航海、公路運輸的行李識別、存貨、倉儲、物流運輸管理...
Ø門禁管制:人員出入門禁監控、管制、上下班人事管理...
Ø自動控制:汽車、家電、電子業之組裝生產...
Ø回收資產:棧板、貨櫃、台車、籠車等可回收容器管理...
Ø物料處理:工廠的物料清點、物料控制系統...
Ø廢物處理:垃圾回收處理、廢棄物管控系統...
Ø醫療應用:醫院的病歷系統、危險或管制之生化物品管理...
Ø防盜應用:超市的防盜、圖書館或書店的防盜管理...
Ø動物監控:畜牧動物管理、動物識別、野生動物生態的追蹤...
Ø聯合票證:聯合多種用途的智慧型儲值卡、紅利積點卡...

How to repair and clone disk with ddrescue

  ddrescue  is a tool that can be used to repair and clone disks on a  Linux system . This includes hard drives, partitions, DVD discs, flas...